Cova Pay Canada Delayed Payouts

Incident Report for Cova Status Updates

Resolved

We are in direct communication with clients affected by the payout delay today and so this general status page update will be closed now. Please contact covapaysupport@covasoftware.com if you are affected by this issue and have not yet been in contact with Cova for updates.
Posted Jun 16, 2026 - 16:57 MDT

Update

We continue to look into this issue regarding some Cova Pay Canada payments being delayed. Thank you for your continued patience.
Posted Jun 16, 2026 - 14:53 MDT

Identified

We have become aware of an issue affecting Cova Pay Canada whereby affected users may see a delay in their scheduled payouts. The Cova Pay team is currently working to resolve the issue for affected clients but cannot currently provide an ETA on a resolution.

Integrated payments can still be completely in-store as normal, and users of Cova Pay in the US are not affected by this. Thank you for your patience as we work towards a resolution.
Posted Jun 16, 2026 - 12:47 MDT
This incident affected: Integrated Payment Services.