Cova Pay error

Incident Report for Cova Status Updates

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 09:36 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 21, 2025 - 08:38 MDT

Identified

Payment processing has been redirected to another endpoint and services have been restored. We will continue to monitor.
Posted Aug 21, 2025 - 08:38 MDT

Update

A service disruption with our payment processor has been identified and they are investigating the issue.
Posted Aug 21, 2025 - 08:29 MDT

Update

The Cova team has identified that putting the payments terminal in stand alone mode will allow users to still transact with card payments. Please see the help article to turn on this service https://support.covasoftware.com/covasupport/s/article/Selling-with-Cova-Pay-Integrated-Card-Payments#manual_home
Posted Aug 21, 2025 - 08:26 MDT

Investigating

We have scattered reports of payments failed through Cova Pay Canada. The team is currently investigating.
Posted Aug 21, 2025 - 08:11 MDT
This incident affected: Integrated Payment Services.