Adyen has confirmed that all Interac issues have been resolved. You can review the Incident on Adyen's status page here: https://status.adyen.com/incident-history#2026. Thank you for your patience while we waited on a full resolution.
Posted Sep 10, 2026 - 16:03 MDT
Update
We are continuing to monitor the Interac Error rates and while we have seen improvements, Adyen has not shared that the issue has been fully resolved. While full resolution is outside of our control, will continue to provide updates as they become available. You can also review the Incident Updates on Adyen's status page here: https://status.adyen.com/incident-history#2026. Thank you for your continued patience.
Posted Sep 10, 2026 - 15:56 MDT
Update
Adyen has identified an issue outside of their platform resulting in higher error rates for transactions processed through Interac. Cova is aware and monitoring the issue. While full resolution is outside of our control, we will continue to update you as we have more information. You can review the Incident Updates on Adyen's status page here: https://status.adyen.com/incident-history#2026
Posted Sep 10, 2026 - 15:12 MDT
Monitoring
Adyen has identified an issue outside of their platform resulting in higher error rates for transactions processed through Interac. Cova is aware and monitoring the issue. While full resolution is outside of our control, we will continue to update you as we have more information. You can also review the Incident Updates on Adyen's status page here: https://status.adyen.com/incident-history#2026. Thank you for your patience.
Posted Sep 10, 2026 - 14:40 MDT
This incident affected: Integrated Payment Services.