Pricing Tab in Catalog - Update

Incident Report for Cova Status Updates

Resolved

The pricing service slowness has been resolved. Should we see any further impact we will provide additional updates.
Posted Apr 16, 2025 - 18:47 MDT

Identified

We are again seeing intermittent timeouts when accessing the pricing tab via my catalog. Our teams are taking corrective measures to resolve the issue and we will provide updates as the service returns to normal.
Posted Apr 16, 2025 - 18:36 MDT
This incident affected: Catalogs and Pricing.