Cova Support - unable to accept incoming calls
Incident Report for Cova Status Updates
Resolved
The issue that was causing calls to fail to reach Cova Support has been resolved. Thank you for your patience during this time and we apologize for any inconvenience caused by this.
Posted Oct 16, 2023 - 15:51 MDT
Investigating
Currently, calls coming into Cova Support are not being correctly routed. At this time, we recommend that clients access support by Chat instead by going to our help page at https://support.covasoftware.com/covasupport/s/ and hitting "chat with an expert" in the bottom right, or by hitting the "help" button in the top right corner while logged into the Cova hub.
Posted Oct 16, 2023 - 14:59 MDT