We are no longer seeing any issues related to Cova Pay integrated payments. Thank you for your patience as we waited for this issue to be resolved.
Posted Apr 21, 2025 - 12:21 MDT
Update
We are beginning to see more successful Cova Pay transactions occurring but not 100% of attempts are successful yet. We will continue to monitor and provide updates as they become available.
Posted Apr 21, 2025 - 11:56 MDT
Update
Our payment processor has identified that they are expericing a DDOS (distributed denial of service) attack, which is currently overwhelming their services and is causing the issues we are seeing with Cova Pay. This kind of attack does not expose sensitive information, but instead simply aims to shut down services by making too many requests. We will continue to provide updates as they become available.
Posted Apr 21, 2025 - 11:38 MDT
Identified
We are currently seeing issues with the Cova Pay integrated payment solution. Affected users may see that sales made using the Cova Pay payment method may not go through successfully.The appropriate teams have been alerted and are investigating further.
Posted Apr 21, 2025 - 11:22 MDT
This incident affected: Integrated Payment Services.