Cova Service Disruption - August 19 2026 - Customer Issue

Incident Report for Cova Status Updates

Resolved

Our teams have confirmed the latency in the Customer service has fully resolved and errors have ceased. Thank you for your patience.
Posted Aug 19, 2026 - 19:20 MDT

Update

We are continuing to monitor as services normalize and will provide additional updates until fully resolved.
Posted Aug 19, 2026 - 18:31 MDT

Update

We are continuing to see general improvements to requests related to Customers in Cova, but as we still see some events in the backlog for services to catch up, we are continuing to monitor until we are confident this is fully resolved.
Posted Aug 19, 2026 - 17:29 MDT

Update

We are still seeing some intermittent issues related to the Cova Customers service, and continue to monitor until we are confident this has been resolved. Thank you for your patience.
Posted Aug 19, 2026 - 16:37 MDT

Update

We are seeing Customer events returning to normal service levels but will continue to monitor to ensure that this issue is fully resolved. Thank you for your continued patience.
Posted Aug 19, 2026 - 15:48 MDT

Monitoring

We are seeing the Customer service is continuing to process the backlog of events. We are seeing the service continue towards a resolution but we cannot currently provide an estimate on when services will be fully returned to normal responsiveness.
Posted Aug 19, 2026 - 15:24 MDT

Identified

We have identified and issue with the service that handles Customers in Cova. Affected users might have difficulty creating or searching for Customers in the Cova hub or the Cova app, or search results might be returned slower than normal. We aware of this issue and are currently working towards a resolution. We do not have an ETA on a solution at the moment but will provide updates as they become available.
Posted Aug 19, 2026 - 14:32 MDT
This incident affected: Customers.