Cova Service Disruption - Biotrack communication issues - Oct 30 2023
Incident Report for Cova Status Updates
Resolved
This Incident has been resolved. Our clients are able to load Biotrack manifests as expected and transactions are submitting through from Cova to the Traceability System as we expect
Posted Oct 30, 2023 - 10:45 MDT
Investigating
We are currently seeing an issue communicating with Biotrack that may affect the ability to receive manifests or in some States, the ability to make sales. We are currently investigating and will continue to provide updates as they become available.
Posted Oct 30, 2023 - 10:05 MDT
This incident affected: Traceability.