After continuing to monitor the impacted services, we are no longer seeing issues with the promotion module and are closing out this incident. Thank you for your patience while we worked to resolve this disruption.
Posted Feb 18, 2026 - 13:07 MST
Monitoring
Response times for the Promotions service have returned to normal performance. We will continue to monitor before closing out this service disruption.
Posted Feb 18, 2026 - 12:37 MST
Identified
We are beginning to see response times improve as additional resources have been added to the impacted services. We will continue to monitor performance and provide updates as the promotion services normalize.
Posted Feb 18, 2026 - 12:32 MST
Investigating
We are currently investigating latency with the Promotions module in HUB. The page is taking longer than expected to load and the team is troubleshooting the delay. We will provide an update once the issue has been identified. No other services are impacted and promotions are working as expected on the POS.