Payment Disruption - Canada
Incident Report for Cova Status Updates
Resolved
Our teams have verified that services have returned to normal. Thank you for your patience while we worked to resolve this issue.
Posted Sep 01, 2023 - 11:05 MDT
Identified
The issue has been identified and our teams are seeing improved performance.
Posted Sep 01, 2023 - 10:46 MDT
Investigating
We are currently investigating an issue with Canadian payment processing.
Posted Sep 01, 2023 - 10:28 MDT
This incident affected: Integrated Payment Services.