Cova Service Disruption - Pricing Update Delays

Incident Report for Cova Status Updates

Resolved

Affected services have returned to normal functionality and we believe this should be fully resolved now. Thank you for your patience as we worked to resolve this.
Posted May 07, 2026 - 16:02 MDT

Monitoring

We are currently seeing an issue with the service that manages Pricing in Cova. This may result in users noticng that changes to Pricing in Cova take longer than usual to be reflected in the Cova app or in online menus.
Posted May 07, 2026 - 15:09 MDT
This incident affected: Catalogs and Pricing and Sales and Orders.