Our payment processor declared the issue fully resolved at 8:30 PM PST, so this incident is now being closed as we believe the issue should no longer be occurring. Thank you for your patience as we waited for a full resolution of this issue.
Posted Apr 22, 2025 - 00:33 MDT
Update
Although we have not seen the issue resolve at this point, we can see that almost all Cova Pay transactions are going through successfully. We will continue to monitor this issue after end of business day as we are not yet confident this has been fully resolved.
Posted Apr 21, 2025 - 17:32 MDT
Update
We are still seeing some Cova Pay payments fail to successfully finish on payment terminals and are continuing to monitor the issue. This status incident will be closed once we are more confident that this is no longer occurring and we will continue to provide updates in the meantime.
Posted Apr 21, 2025 - 15:25 MDT
Update
We are still seeing some Cova Pay payments fail to successfully finish on payment terminals and are continuing to monitor the issue. This status incident will be closed once we are more confident that this is no longer occurring and we will continue to provide updates in the meantime.
Posted Apr 21, 2025 - 14:24 MDT
Monitoring
We are seeing that the Cova Pay issues are beginning to re-occur due to a second round of DDOS attacks against our payment processor and we are reopening this incident to continue looking into this.
We apologize for the confusion and inconvenience during this time. We will continue to provide updates as they become available.
Posted Apr 21, 2025 - 12:54 MDT
This incident affected: Integrated Payment Services.