We have finished monitoring the Pricing issue from earlier today and we are confident that the service has returned to normal operational levels. Thank you for your patience as we monitored and resolved this issue.
Posted Apr 16, 2025 - 15:54 MDT
Update
We continue to monitor the known issue with the Pricing service and while we have seen a large amount of improvement, we have not yet seen a full recovery. Thank you for your continued patience as we wait to see this service behaving at normal levels again.
Posted Apr 16, 2025 - 13:03 MDT
Update
We continue to monitor the known issue with the Pricing service and while we have seen a large amount of improvement, we have not yet seen a full recovery. Thank you for your continued patience as we wait to see this service behaving at normal levels again.
Posted Apr 16, 2025 - 11:22 MDT
Monitoring
We have identified the issue with the Pricing service and are seeing some initial improvement. We are still monitoring before declaring the issue resolved. For users still seeing issues loading prices, reloading the webpage will probably help as most requests are going through successfully.
Posted Apr 16, 2025 - 09:23 MDT
Investigating
We are aware of an issue causing slow loading or no loading of the pricing tab in Catalog. We are actively investigating the degraded performance and will update as soon as we know more.