Cova Pay Canada Only - External issue with Cloudflare impacting Payment Processing

Incident Report for Cova Status Updates

Resolved

We can confirm that as of 19:55 CET, the external issue which temporarily affected payment processing has fully recovered, and all services are operating as expected.
Posted Feb 20, 2026 - 13:06 MST

Identified

We've been notified by our payment processor Adyen that they are observing an external issue with Cloudflare, starting at 19:30 CET on February 20, 2026.

Their engineering teams are involved and working toward mitigating the impact. Payment processing through our systems appears to be impacted intermittently.

We will provide updates as further information becomes available.
Posted Feb 20, 2026 - 12:14 MST
This incident affected: Integrated Payment Services.