We believe the issue with Pricing services in Cova is now fully resolved. We apologize for the inconvience and thank you for your patience as we worked to resolve this.
Posted Apr 21, 2025 - 12:42 MDT
Update
We are continuing to monitor Pricing services to ensure that related services are behaving normally again. We believe that the issues are no longer occurring but we are continuing to monitor to ensure service continues smoothly as many users are setting new prices after the weekend.
Posted Apr 21, 2025 - 12:35 MDT
Monitoring
We have seen that the Pricing issue is mostly cleared up but we are continuing to monitor affected services before calling the all-clear. Thank you for your patience and we will continue to provide updates until we are confident this is no longer occurring.
Posted Apr 21, 2025 - 11:52 MDT
Identified
We are currently seeing some issues related to the Pricing service within Cova. This service affects many other parts of Cova and affected users may see errors when attempting to set prices in the Cova hub, or delays in saved changes being represented in the Cova app. We are aware of the issue and working on a resolution but cannot currently provide an ETA on a solution.
Posted Apr 21, 2025 - 11:19 MDT
This incident affected: Catalogs and Pricing and Hub.