Delays in Inventory Manager

Incident Report for Cova Status Updates

Resolved

The incident with delays in inventory manager have been resolved.
Posted Aug 05, 2026 - 15:27 MDT

Update

Cova is aware of an issue that is causing delays in newly received inventory appearing in the system and pricing updates being reflected. Our team is actively investigating and monitoring the issue, and we expect it to be fully resolved within the next 15–20 minutes.
Posted Aug 05, 2026 - 14:52 MDT

Monitoring

Cova is aware of an issue that is causing delays in newly received inventory appearing in the system and pricing updates being reflected. Our team is actively investigating and monitoring the issue, and we expect it to be fully resolved within the next 15–20 minutes.
Posted Aug 05, 2026 - 14:52 MDT
This incident affected: Catalogs and Pricing.